Browser Requirements

Desktop Browser

CLTS is tested against and supports the following desktop browsers:

  • Microsoft Windows 10 and newer
    • Google Chrome (latest stable version)
    • Firefox (latest stable version)
    • Microsoft Edge (latest stable version; Chromium-based only)
    • Internet Explorer: While CLTS supports version 11 of Internet Explorer, we recommend you use Google Chrome for an optimal experience.
  • MacOS 10.12 and newer
    • Google Chrome (latest stable version)
    • Firefox (latest stable version)
    • Safari (latest stable version)

Mobile Web Browser

You can access CLTS through the following mobile browser:

  • Android 5 and newer
    • Google Chrome (latest stable version)
    • Firefox (latest stable version)
  • iOS 10 and newer
    • Google Chrome (latest stable version)
    • Firefox (latest stable version)
    • Safari (latest stable version)

Please note that in downloading the supported browser, you acknowledge that these are third-party sites and that CCIA cannot take responsibility for the consequences of your downloading browsers.

SSL encryption

To access our services, your browser must also support 128-bit Secure Sockets Layer (SSL) encryption. All the browsers we support meet this requirement. If your browser does not meet this requirement, please download the appropriate encryption support from your browser's supplier.

JavaScript

To access our services, you must change your browser and/or device settings to enable JavaScript. For more information on enabling JavaScript, please refer to your browser's Help section or documentation.


7.18.0